By using AWS re:Post, you agree to the Terms of Use

Uploading object is good, but downloading isn't getting latest version of the object


I've used S3 for several years...we upload objects into our buckets, no versioning enabled, no encryption. So I'm updating one of our objects...the upload of the new object works well...and to verify this upload worked, I immediately click on the "Download" button from the S3 control panel, (I've also tested the "Open" button and the "Object actions" button)...and these actions verifies the object is correct...the download works flawlessly. However, if I use the "Object URL" to download the object...I do NOT get the latest version of the object...I get an older version.

1 Answers

Strong consistency in S3 was introduced in Dec, 2020 so you should not be noticing the behavior that you are noticing.

Are you using Cloudfront in front of S3. If yes, Cloudfront may have cached the older version of the object.

profile picture
answered 14 days ago
  • What is "Cloudfront"? The failure is occurring when I copy the "Object URL" and paste it into a browser window.

    It appears I do not have CloudFront enabled on our account. So why is my updated object still not available for download? I just tested it's been 13-hrs since I uploaded the object, and the "Object URL" is still not delivering the updated object.

    So...I experimented...I "renamed" the object in my control panel...and that renamed object DOES contain the correct content (validated by download via the "Object URL"). However, if I rename the object back to the original name...that "Object URL" does NOT download the updated content, it downloads the old version of the object.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions