Client.UnsupportedHostConfiguration whne trying to allocate mac1.metal instance

0

I would like to allocate a dedicated mac1.metal host on my account. The Service quota says I can allocate up to three, but the request fails. I tried multiple AZs and Regions - same result


➜  ~ aws  service-quotas list-service-quotas --service-code ec2 --query "Quotas[?QuotaName == 'Running Dedicated mac1 Hosts']"
[
    {
        "ServiceCode": "ec2",
        "ServiceName": "Amazon Elastic Compute Cloud (Amazon EC2)",
        "QuotaArn": "arn:aws:servicequotas:eu-central-1:40....46:ec2/L-A8448DC5",
        "QuotaCode": "L-A8448DC5",
        "QuotaName": "Running Dedicated mac1 Hosts",
        "Value": 3.0,
        "Unit": "None",
        "Adjustable": true,
        "GlobalQuota": false
    }
]

Here is the relevant cloud trail log for the detail.

{
    "eventVersion": "1.08",
    "userIdentity": {
        "type": "IAMUser",
        "principalId": "AI....62O",
        "arn": "arn:aws:iam::40....46:user/sst",
        "accountId": "40.....46",
        "accessKeyId": "AS.....35D",
        "userName": "sst",
        "sessionContext": {
            "sessionIssuer": {},
            "webIdFederationData": {},
            "attributes": {
                "creationDate": "2022-07-30T11:19:43Z",
                "mfaAuthenticated": "true"
            }
        }
    },
    "eventTime": "2022-07-30T11:21:24Z",
    "eventSource": "ec2.amazonaws.com ",
    "eventName": "AllocateHosts",
    "awsRegion": "us-east-1",
    "sourceIPAddress": "AWS Internal",
    "userAgent": "AWS Internal",
    "errorCode": "Client.UnsupportedHostConfiguration",
    "errorMessage": "The requested configuration is currently not supported. Please check the documentation for supported configurations.",
    "requestParameters": {
        "AllocateHostsRequest": {
            "HostRecovery": "off",
            "AutoPlacement": "off",
            "AvailabilityZone": "us-east-1f",
            "Quantity": 1,
            "InstanceType": "mac1.metal",
            "TagSpecification": {
                "ResourceType": "dedicated-host",
                "tag": 1,
                "Tag": {
                    "Value": "xxx Demo",
                    "tag": 1,
                    "Key": "Name"
                }
            }
        }
    },
    "responseElements": null,
    "requestID": "2506eca6-fb62-4354-98f5-8e536e623f1b",
    "eventID": "1f9ae005-dadc-445d-b6a1-9b2b21ce0073",
    "readOnly": false,
    "eventType": "AwsApiCall",
    "managementEvent": true,
    "recipientAccountId": "40.......46",
    "eventCategory": "Management",
    "sessionCredentialFromConsole": "true"
}
sebsto
asked 4 months ago77 views
1 Answer
0

Hello sebsto,

The service quota for running dedicated mac1 host isn't global [1]. Since the quota ARN contains eu-central-1, have you tried launching a dedicated host from that region instead? Additionally, you can also check the service quota for running dedicated mac1 host in your intended us-east-1 region by specifying the region:

aws --region us-east-1 service-quotas list-service-quotas --service-code ec2 --query "Quotas[?QuotaName == 'Running Dedicated mac1 Hosts']

Before launching mac1 instance, you must allocate a dedicated host in the correct region. You can follow this guide [2] to create a Mac1 dedicated host.

Also, be aware that Mac dedicated host doesn't support multiple instance types [3], so you should disable support multiple instance types if you're launching the host from the CLI.

Lastly, if your issue still persist, you can open a support case for further assistance.

Best,

1: list-service-quotas CLI docs

2: Creating Mac dedicated host guide

3: Mac dedicated host limit

Triet_V
answered 3 months ago
SUPPORT ENGINEER
reviewed 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions