By using AWS re:Post, you agree to the Terms of Use

Amplify GitHub integration failing in ca-central-1

0

We have multiple Amplify applications running in multiple regions. Yesterday we tried to connect a new branch to an application in ca-central-1. We were sent to the "AWS Console Add Repository Branch" screen, like usual, but then redirected to GitHub where we were asked to install the aws-amplify application. On GitHub we were then asked to pick the specific repositories that AWS-Amplify could access.

I had never seen this screen before and it is not the workflow shown in the Amplify documentation.

I selected the repositories to which AWS-Amplify ALREADY has access. The workflow stopped at that point; it dit not ask me which branch to connect.

I went back to AWS Amplify console and tried again. Same issue.

I was not given a chance to choose a branch.

I repeated this a few more times.

Then I tried it in us-east-1. It worked as normal.

Then I tried to create a new web application in ca-central-1. One of the first screens asks me to choose a repository. When I chose GitHub I was sent to GitHub, just like what had happened when I tried to connect a branch in ca-central-1 and the workflow stopped - I could not create the application.

I tried to create a new web application using manual deploy. It worked.

Now, when I try to connect a branch to the same application that I had problems with yesterday, it works.

I found no questions about this when Googling nor any issues reported on the AWS status/health check pages. It started yesterday or on the weekend- we successfully attached new branches and deployed them for the same app/region on the weekend.

I'm sorry that I don't have screen shots. This is my first re:Post question and I wanted to see how it works (i.e. are attachments even allowed) prior to gathering that information, and now, of course, things are working.

Is anybody aware of any region specific hiccups with AWS-Amplify GitHub integration over the weekend.