AWS WorkMail Spam filter too sensitive



I've noticed that lots of legitimate e-mails received via WorkMail are classified as Spam. This is not an isolated incident where the Spam filter is a little bit too sensitive – this is something that happens on a regular basis with e-mails where neither the content nor the sender address may indicate spam. The senders are usually private customers who are sending their mails with a widely used freemail provider.

Unfortunately, CloudWatch only allows me to see if a message was marked as spam or not, it does not allow me to see why a message was declared as spam. So I'm not sure how to further troubleshoot this issue.

Please let me know if there's anything I can do to deactivate the Spam filter or to lower its sensitivity. Any general advice on how to troubleshoot this further is also appreciated.

asked a year ago160 views
1 Answer
Accepted Answer


I'm sorry to hear you're experiencing problems with legitimate emails being marked as spam. There is no way to turn off the spam check for WorkMail but you can create a Email flow rule which can be configured to ignore the spam classification and deliver the message to the inbox:

Another option that might cause messages to go to spam is the DMARC enforcement: But that would mean senders have incorrectly configured sending domains.

Kind regards, Robin

answered a year ago
  • Thanks for your reply.

    It's unlikely that DMARC is the cause of our issue. The e-mails are sent from very large and well-known mail providers, so I assume they didn't make any huge configuration error that causes them to be flagged as spam. I also noticed that some e-mails that we have sent via SES were marked as spam, and when I removed a few words from the subject line and sent the same e-mail again, it suddenly wasn't marked as spam anymore. And the words that I had removed did not indicate spam (no uppercase letters, exclamation marks or anything like that). This was reproducible, and I did not change anything other than removing a few words from the subject line.

    I would prefer a working spam filter, but as a workaround, I'm probably going to create an E-Mail flow rule to ignore spam classification for all senders.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions