why does using System Manager aws:runShellScript to execute "df -h" not show EFS mounts

0

When I run the df command on my servers the results displayed show my EFS mounts. when I run the command using System Manager and doc aws:runShellScript the EFS mounts are not show but all non EFS mounts are shown. Why is this ? Am I missing a parameter ? These are RHEL 7.9.

asked 2 years ago277 views
1 Answer
1

Hello there,

Thank you for reaching out to us and posting your question in Re:Post. I tested AWS-RunShellScript Command document in a RHEL 7.9 instance to run df -h. I mounted EFS using both nfs4 and efs filesystem type. In either case the df -h command displayed the EFS mounts. You may check:

  1. If the EFS filesystem is mounted when the Systems Manager document executes.
  2. If you are using the latest Systems Manager agent. Ref: https://docs.aws.amazon.com/systems-manager/latest/userguide/agent-install-rhel.html

If this is reproducible, please feel free to open a Support case with us and we can investigate further.

AWS
SUPPORT ENGINEER
answered 2 years ago
  • EFS mount point is created in Instance via Bootstrap. when the same instance is Rebooted EFS does not Automatically Mounts HELP?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions