Skip to content

Unable to deploy CloudFormationTemplate

0

Hi - I am using the CloudFormation Template from the AWS SaaS Integration page here https://docs.aws.amazon.com/marketplace/latest/userguide/deploy-serverless-saas.html I am trying to register my company's product using the Sample Registration app provided by AWS. I have used a brand new AWS Account and I do have admin role access.

Before creating the Stack in the CloudFormation Service, I do provide values for all the required parameters and then create the Stack.

Upon submission of the request I see 3 events which are successful. However the 4th event fails with the following error: The following resource(s) failed to create: [RegisterNewMarketplaceCustomer, SubscriptionSQSHandler, EntitlementSQSHandlerMySQSEvent, LambdaEdgeRedirectPostRequests, WebsiteS3BucketLog, Hourly, SubscriptionSQSHandlerMySQSEvent, MeteringSQSHandler, EntitlementSQSHandler, WebsiteS3Bucket, GrantOrRevokeAccess].

I dont see any other information as to why it failed

Has anyone faced this error and if yes resolved this successfully? Please share any steps if you have resolved a similar error

1 Answer
1

Hello.

When CloudFormation deployment fails, I think some error message is output.
Could you please share that error message?
https://docs.aws.amazon.com/AWSCloudFormation/latest/UserGuide/troubleshooting.html

Also, please check the quota of each AWS service as it is possible that the service quota has been exceeded and an error has occurred.
https://aws-ia.github.io/cloudformation-aws-marketplace-saas/
a

Please check the following document regarding service quotas.
https://docs.aws.amazon.com/servicequotas/latest/userguide/intro.html

EXPERT

answered 2 years ago

EXPERT

reviewed 2 years ago

  • Hi I tried once more and this time the deployment proceeded to create more resources. I did not hit any service quota issues in the current attempt as well as the previous attempt The error I am getting this time is : Embedded stack arn:aws:cloudformation:us-east-xxxxx:stack/marketplace-saas-xxxxx-SampleApp-1XPML9VKE3BA1/7cdeb7d0-2781-11ef-99f2-0e4dc2c8eb13 was not successfully created: The following resource(s) failed to create: [EntitlementSQSHandlerMySQSEvent, SubscriptionSQSHandlerMySQSEvent, HourlyCWSchedule]

    Further the rollback is failing now with the following error and the cleanup is not complete too Resource handler returned message: "Lambda was unable to delete arn:aws:lambda:us-east-xxxxxx:function:marketplace-saas-xxxxx-LambdaEdgeRedirectPostRe-OjeDg0X00UKi:1 because it is a replicated function. Please see our documentation for Deleting Lambda@Edge Functions and Replicas. (Service: Lambda, Status Code: 400, Request ID: 0d8f4ca4-cdd5-476f-8b25-edc70e69f09e)" (RequestToken: f0667b85-0e8e-48bb-f670-a4fd2a9a6019, HandlerErrorCode: InvalidRequest)

    Could you please update if any one ran into this error and was able to resolve?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.