Restore from glacier does not seem to work...

1

Hi everyone,
So I manually restored a file from the glacier storage. After a while, it says restoration complete, shows me the restoration expiry as well. However, at the same time, it also shows a warning that the file is in glacier and therefore cannot be accessed. Is this supposed to happen? Or have I done anything wrong? I am still not able to view the file. I understand that a temporary copy is moved to RRS after restoration. So where can I view that file?

Also, is there any way to transfer the temporary copy of the file to STANDARD storage after restoration?
Thanks so much!

asked 3 years ago1209 views
4 Answers
0

Hi aliengood1729,

The behavior which you are observing is expected. You will be able to open the file, to view the content once the file is restored. Please note that whenever an object is restored from Glacier storage class, even after restoration, the storage class of object remains same. In restoration process, S3 creates temporary copy of the actual object (which is in Glacier) which is available for amount of restoration period you chose while initiating the restore process. So, even after restoration, the actual object still remains in the same storage class.

Also you cannot move the temporary copy to a different storage class. You can download the object and then copy it to a new location in the same S3 bucket in Standard Storage class.

Please feel free to reach out for further queries or concerns.

Best regards

AWS
SUPPORT ENGINEER
Isha_P
answered 3 years ago
0

Hi.

Big thanks for reaching out! Do I really need to download the files to the PC and re-upload again? That was not the case when I worked on the last Glacier Archive that I started to sync between regions a few years back, then I could copy the restored object to the same bucket as it is recovered in and using that copy I could move it to another bucket.

On the page https://docs.aws.amazon.com/AmazonS3/latest/userguide/restoring-objects.html I can read "If you want a permanent copy of the object, create a copy of it in your Amazon S3 bucket." which is what I want to do but can't find the way to do.

eljest
answered 2 years ago
0

This is old, but I have the same issue.

I have restored some objects from glacier, but when I click on them in the Console now I get two messages:

This object is stored in the Glacier Flexible Retrieval (formerly Glacier) storage class In order to access it you must first restore it.

and

Restoration complete Learn more about restoring archived objects Restoration status Completed

I have tried to move the objects with the Console and via the CLI and it doesn't work.

What step are we missing?

Corin
answered 6 months ago
0

OK, the real answer looks to be:

--force-glacier-transfer

As per https://github.com/aws/aws-cli/issues/1699, if you want to access the objects in bulk, using, for example, aws s3 cp, you need to add the flag to force the operation.

Individual objects can be downloaded and accessed after the restoration but it looks like actions on groups of objects need this extra flag.

Corin
answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions