By using AWS re:Post, you agree to the Terms of Use
/Unable to access Kibana REST API/

Unable to access Kibana REST API

0

Hi,

I’m using the ElasticSearch service on a VPC with basic authentication.
I am able to make ES REST API calls, but Kibana API calls fail with 401 status code - "Authentication required". Kibana UI works well.

For example, the following API call works:
curl -u user:pass -H 'Content-Type: application/json' -X GET <vpc-es-endpoint>/_search

But this one fails with status 401:
curl -u user:pass -H 'Content-Type: application/json' -X GET <vpc-es-endpoint>/_plugin/kibana/api/saved_objects/index-pattern/<id>

Any idea what could be the problem?

Thanks

asked a year ago31 views
3 Answers
0

I am also facing the same issue. I tried every options

answered a year ago
0

Hi,

I managed to make it work by calling /_plugin/kibana/auth/login and then using the security_authentication cookie when calling Kiabana API.

First call:
curl -u user:pass -H 'Content-Type: application/json' -X POST <vpc-es-endpoint>/_plugin/kibana/auth/login' -H 'kbn-xsrf: true' -d '{"username" : <username>, "password" : <password>}' -c /tmp/kibana_cookies.txt

Next calls:
curl -u user:pass -H 'Content-Type: application/json' -X GET <vpc-es-endpoint>/_plugin/kibana/api/saved_objects/index-pattern/<id> -b /tmp/kibana_cookies.txt

Or:
curl -u user:pass -H 'Content-Type: application/json' -X GET <vpc-es-endpoint>/_plugin/kibana/api/saved_objects/index-pattern/<id> --cookie 'security_authentication=<security_auth_cookie>

answered a year ago
0

Cool. It worked. Once security cookie is available, I think user:password is no longer needed. One issue I am facing is that visualization created in elastic version of kibana (7.9.x) is failing to import into AWS ES kibana 7.9. We use the _import api end point

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions