Cannot save a new Glue Job on creating because the IAM Roles are always empty

1

Although all related and all required roles and policies were added, on creating a new Glue Job no IAM Roles are listed at all, and the new Glue Job details cannot be saved, find the attached image below: No IAM Roles are listed while adding a new Glue Job

What could be the cause of this?

asked a year ago441 views
1 Answer
0

You need to follow step 2 on creation of an IAM role for a Glue Job. https://docs.aws.amazon.com/glue/latest/dg/create-an-iam-role.html

Also sometimes when I get stuck on building a solution, one I take a break :). Two, I try to find a workshop that will "imitate" what I am working to building AWS.

https://catalog.us-east-1.prod.workshops.aws/workshops/91c9f70c-0437-4109-b6e0-69136b03a555/en-US Give this workshop a try perhaps if step 2 was already tried out.

Let me know if you have any issues with this, or if it helps you then please accept my answer after you've tried it out - it would be much appreciated! Good luck :)

profile picture
D G
answered a year ago
  • Hi D G, thank you for your answer and information, however the "Step 2" in the docs was already completed actually. Unfortunately, the workshop did not provide the needed information as well.

  • @rePost-User-4678286 You are creating the role first... the refreshing the glue job "wizard" and the IAM role isn't showing up? What if you type the name of the role ? Something is off here.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions