By using AWS re:Post, you agree to the Terms of Use

Unsupported or invalid SSH public key format

0

I have deployed a Transfer Family sftp server (using an Amazon EFS ). I am having trouble configuring the user. I keep getting the error: Failed to create user (Unsupported or invalid SSH public key format)

I have tried using the format according to AWS format but still, get the error. Has anyone had this issue and how did you solve it?

1 Answer
0

Hello, have you tried to use an RSA, ED25519, or ECDSA key type as the user's public key? These are the current key types supported for AWS Transfer users. There are detailed instructions on generating SSH key pairs in the AWS Transfer Family User Guide found here. If you continue to experience issues, please create a support case.

answered 23 days ago
  • I actually read that document and used puTTY generator initially. However, after some additional research, I discovered that the output format was incorrect. I should have used the format starting with ssh- rsa. So I modified the file in that format and now it works! Thx for your response!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions