By using AWS re:Post, you agree to the Terms of Use

ACM certificate validation status is still pending and CNAME record isn’t added to the correct DNS configuration

0

I created a hosted zone for a valid registered domain ” skillbuilder.training.aws.dev” in Route 53. Then requested a public certificate with DNS validation for the domain name in ACM and also created the record accordingly. This added CNAME record in the hosted zone(Route 53). Now, the certificate is still under pending stage. When I tried the test record in Route 53, it returns empty response. I verified the CNAME,

  • there is no additional characters or is missing characters
  • there is no repeating bare domain to the end of its DNS records

I also tried the dig command on generated CNAME, getting Record not found. Please provide some assistance.

1 Answers
1
Accepted Answer

Hello There,

ACM is unable to verify the CNAME record due to that you're seeing the state "pending".

If you added the CNAME in the record correctly and the dig is not showing the response, then it might be the case where you have added to the wrong hosted zone (meaning you might have multiple hosted zones).

Check your hosted zone NS server records where you have added the CNAME record are matching to the below set or not.

%dig NS skillbuilder.training.aws.dev +short ns-1505.awsdns-60.org. ns-1811.awsdns-34.co.uk. ns-856.awsdns-43.net. ns-3.awsdns-00.com.

if not, most likely you need to find on which account you have this Hosted zone and you need to add their.

Regards, CK

profile picture
answered 24 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions