By using AWS re:Post, you agree to the Terms of Use
/ebs volume - can't read data/

ebs volume - can't read data

0

hi guys, so i have this volume: vol-0f057741ae7be8974 - this worked till today. today my instance stopped working and when i attached this volume to another instance, i can't read the data off it. is there any chance we could recover the data? i forgot to take a snapshot of it :/

i have also tried taking a snapshot of the volume and creating another volume but still no dice on mounting it:

mount: wrong fs type, bad option, bad superblock on /dev/xvdg,
missing codepage or helper program, or other error

   _In some cases useful info is found in syslog - try_  
   _dmesg | tail or so._  

[ 3074.328710] XFS (xvdg): Invalid superblock magic number

thanks in advance

Edited by: katmai on May 11, 2018 11:20 AM

asked 4 years ago1 views
1 Answers
0

Was the volume encrypted?

I would suggest take a snapshot, create a volume, attach to a new Linux machine and then:

1) Check the output of

fdisk -l /dev/xvdg

2) Run

xfs_check /dev/xvdg1

3) Check what you get

sudo xfsdump -f /dev/xvdg1 | grep -i superblock

4) Still no luck then try sudo mkfs.xfs -N /dev/xvdg1 . If you see some numbers there, you may be able to recover the device using a tool like http://www.ufsexplorer.com/

If nothing works, you are probably out of luck.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions