By using AWS re:Post, you agree to the Terms of Use
/Aurora MYSQL Max_Connections Number/

Aurora MYSQL Max_Connections Number

0

Hello everyone, I'm facing a little issue with my Aurora MYSQL database, I keep changing the max connections number to avoid 1040 error in my custom parameter group as showed in documentation, but after they say It was changed in RDS events It keeps returning to default value (180 for 2 instances in my case), I wonder if someone faced the same issue and how to fix that, thank you.

1 Answers
0
Accepted Answer

Hi there!

From the notes, I understand that you managed to create a custom parameter group for your DB cluster and changed the max connection value but the value is not reflecting/changing. Please correct me if my understanding is wrong.

Please note that when changing the parameter value of your custom parameter group, you will need to associate the custom parameter group with the DB cluster. Check document in link [1] to confirm the steps to associate a DB cluster parameter group with a DB cluster. Change the check box under “Scheduling and Modifications” from apply during the next maintenance window to apply changes immediately.

Please note that after you change the DB cluster parameter group associated with a DB cluster, a reboot will be required on the primary DB instance in the cluster to apply the changes to all of the DB instances in the cluster.

I hope the above information is helpful.

References:

[1] https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/USER_WorkingWithDBClusterParamGroups.html#USER_WorkingWithParamGroups.AssociatingCluster

answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions