EC2 instance is not reachable by public IP

0

Hey guys,

I understand there is a million questions like this every day. However mine is different. I did not change a thing in my account. All VPC resources were created by Amazon. I tried all troubleshooting tutorials I could find to no avail. I tried launching instances in 3 different regions - same result. Again I did not create/configure any of the VPC stuff, the instance is launched into a default VPC, default subnet and SG is default too.

Thanks,
Denis

asked 4 years ago9306 views
2 Answers
0
Accepted Answer

Hi Denis,

It is expected that you would not be able to reach instance over its public IP with default settings.

default security group associated to the instance, allow inbound traffic from network interfaces (and their associated instances) that are assigned to the same security group.

[+]: https://docs.aws.amazon.com/vpc/latest/userguide/VPC_SecurityGroups.html#DefaultSecurityGroup

Therefore, to access instance over its public IP from your source machine, please add inbound rules to the security group.

To access windows instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

To access linux instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

I hope this helps.

answered 4 years ago
profile picture
EXPERT
reviewed a year ago
0

Oh, man. It's so simple it's embarrassing. Thank you very much!

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions