S3 Bucket Public Access Settings


Hello - we have 15 S3 Buckets setup and we use the AWS PHP library to send and receive files to and from these buckets. When we originally created the buckets we inadvertently left them open to the public. Once we realized our mistake we edited the public access settings and made the buckets and objects not public. Unfortunately when we did this our application could no longer read the files that were already there. We could send and receive new files but the old ones were unavailable. We solved this problem by running a command line script that changed the object ownership to the bucket owner. This seems to have solved our problem with one exception.

Two of our 15 buckets now say Access Denied when we try to view their contents. We performed the exact same actions on all 15 buckets and they are all marked Private. We cannot figure out why 2 of the buckets are not working and why we cannot view their contents through the S3 portal. At the moment the only way we can get these buckets to work is to make them Public but this is not an acceptable option.

Does anyone know how or why the bucket owner would not be able to access the bucket?

Thank You,

asked 5 years ago435 views
1 Answer

We figured out that it was a problem on the permissions page. The issue is now resolved.


answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions