By using AWS re:Post, you agree to the Terms of Use
/Quick Connect Transfers Failing in Amazon Connect/

Quick Connect Transfers Failing in Amazon Connect

0

Agents attempting to transfer callers to other agents and to queues are unable to do so via the quick connects. The behavior we're seeing on the CCP is the INTERNAL CALL banner pops up and it rings for a second before disappearing, leaving the caller on hold. This happens both on inbound calls and outbound calls initiated by agents.

Transfers to outside lines work fine though.

I'm suspecting the call is never making it into the transfer flows. I've tried adding a diagnostic voice prompt that says "Starting transfer" at the beginning of the transfer flows we're using (the built in default queue and agent transfers) and they're never played.

The agents and queues we're transferring to should be available, they are able to grab inbound calls via the IVR and queues, just not accept transfers. But that should be irrelevant if the call is never actually entering the transfer flows to begin with.

Any ideas why this might be failing?

  • Have you turned on logging? Check the logs in cloudwatch, they will tell you exactly what is happening.

  • Hi, did you manage to resolve this?

    I have just had it today on a new Connect instance. Exact same scenario - outside Quick Connects are fine, but queue ones are failing, with default queue transfer flow. If I turn logging on within the Flow, I don't see anything in CloudWatch logs. Also no errors on CCP console window etc.

2 Answers
0

What does your transfer to queue flow look like that is associated to the quick connect?

david

answered 4 months ago
  • It's the default queue transfer flow that's preconfigured by Amazon. I modified it by putting a voice prompt (i.e. saying "Starting transfer flow") to play as the first step before continuing into the pre-defined behavior. This prompt never plays.

    I've also tried it with a queue transfer flow that has two blocks: one explicitly sets the destination queue (although I'd expect this is already set within the quick connect) and then sends it straight to transfer. This also doesn't complete the transfer.

0

I have this aswell, did you managed to resolve it?

answered 9 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions