By using AWS re:Post, you agree to the Terms of Use
/How to disable ufw ?/

How to disable ufw ?

0

Please help me I use Lightsail and set the firewall using Lightsail/ Manage/ Networking/ Ipv4 Firewall rules. There are SSH TCT 22, HTTP TCP 80, MySQL TCP 3306 etc.

When I failed open a web site on that Lightsail, I connected the instance using Putty and run
sudo ufw allow 'Apache Full' and sudo ufw enable.

Since then, I cannot access the instance in anyway. Nothing works !

How can I login to my instance ? Please Help

1 Answers
0

Hi there,

Since you cannot connect to your Lightsail instance via ssh or through the browser-based ssh client after enabling ufw. You can recover your instance by taking a snapshot of it if you did not create a backup on launch and create a new instance from it. When you launch the new instance via console add the following script as a launch script to disable ufw:

sudo service ufw stop

You can also use AWS CLI to launch the new instance from a snapshot by running the following command:

aws lightsail create-instances-from-snapshot --region <snapshot-region> --instance-snapshot-name <snapshot-name> --instance-names <new-instance-name> --availability-zone <preferred-AZ> --user-data 'sudo service ufw stop' --bundle-id <value>

Alternately, you can export your Lightsail snapshot to Amazon EC2 for further troubleshooting by following the steps here and here. Additionally, here is a video tutorial on how to export Lightsail instance to Amazon EC2 instance.

Hope this helps

answered 25 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions