By using AWS re:Post, you agree to the Terms of Use

AWS Workspace Timezone resetting after disable timezone redirection

0

I've followed the documentation and disabled Timezone redirection (https://docs.aws.amazon.com/workspaces/latest/adminguide/group_policy.html#gp_time_zone).

We can now change the timezone on our Workspace instances, but the timezone change doesn't seem to persist (although it did on 2 instances).

I've changed the timezone on an instance to CST, then logging off and back on again the timezone is again at UTC.

Does anyone have any ideas on how to fix this?

  • Hi - Out of interest have you tried to change any other settings using the Workspaces Group Policy administrative template (for example, clipboard redirection) to check that the settings are being applied by the GPO correctly? It may be worth checking this to confirm.

  • @Craig_W - yes, it was definitely working as previously it wouldn't even let me set the timezone. I now had the option changing the timezone but it wouldn't persist when logging off. We fixed it with the help of the suggestions on the accepted answer post below!

asked 5 months ago165 views
1 Answers
1
Accepted Answer

Hi,

Just curious which WorkSpaces OS do you see this issues? Do you know if this issue appears after a reboot of the WorkSpace as well or does it happen only on log on/off? There's a couple of things you can check/try:

  1. Check to see if the WorkSpace computer object in Active Directory located in an OU where the group policy is applied? If it's not, there's a possibility that the settings got reset after the reboot.

  2. The work around described in the documentation suggests GPO configuration, however you can manually try to delete the registry key

HKEYLOCALMACHINE\SOFTWARE\Teradici\PCoIPAgent\ConsoleTimeZone

Note: I would recommend doing this on one specific workspace to test and doing so in a test environment if possible.

  1. Set the time zone using the UI or run "tzutil /s "Central Standard Time" in the CMD

Note: If you could also try to set the timezone during user logon using a logon script.

  1. Then reconnect to the Workspace to test.

Last, you should opens an **AWS Premium Support **case to continue troubleshooting of the issue.

profile picture
EXPERT
answered 5 months ago
  • Thanks @Dzung_N - We're running Windows on server 2016.

    I did reboot the workspaces and had the same issues. I'll had setup a login script to set the time which didn't seem to be working either. I'll give your other options a go and let you know how I get on!

  • I ended up setting key HKEYLOCALMACHINE\SOFTWARE\Teradici\PCoIPAgent\ConsoleTimeZone to Central Standard Time and that fixed all the issues!

    Thanks!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions