ECS Cluster stuck in a busy state for days after capacity provider changes

0

My ECS cluster is stuck in “The specified cluster is in a busy state. Cluster attachments must be in UPDATE_COMPLETE or UPDATE_FAILED state before they can be updated. Wait and try again.” for 2 days.

I tried to make some changes in the capacity provider, which seems to have brought the entire cluster into a stuck “updating” state. I've read a few answers here that indicate that this would fix itself within a few minutes or hours, but nothing seems to be happening.

When I run aws ecs describe-clusters --clusters <redacted_cluster_arn> --include ATTACHMENTS --query clusters\[\].attachmentsStatus I get: [ "UPDATE_IN_PROGRESS" ]

This cluster has no services or tasks. I tried removing everything – registered instances, ASG, services, to no avail. At this point, I'd just like to delete the cluster but can't. Can someone point me in the right direction to erase these blocked resources from my organisation?

Update: here is the cluster description

{
    "clusters": [
        {
            "clusterArn": [REDACTED],
            "clusterName": "ecs-cluster-name",
            "status": "ACTIVE",
            "registeredContainerInstancesCount": 0,
            "runningTasksCount": 0,
            "pendingTasksCount": 0,
            "activeServicesCount": 0,
            "statistics": [],
            "tags": [],
            "settings": [],
            "capacityProviders": [
                "cp-external-ecs"
            ],
            "defaultCapacityProviderStrategy": [],
            "attachments": [
                {
                    "id": [REDACTED],
                    "type": "as_policy",
                    "status": "CREATED",
                    "details": [
                        {
                            "name": "capacityProviderName",
                            "value": "cp-external-ecs"
                        },
                        {
                            "name": "scalingPolicyName",
                            "value": "ECSManagedAutoScalingPolicy-[REDACTED]"
                        }
                    ]
                }
            ],
            "attachmentsStatus": "UPDATE_IN_PROGRESS"
        }
    ],
    "failures": []
}
profile picture
Miguel
asked 2 months ago632 views
2 Answers
0

Hello.

Did you create the ECS cluster from the management console?
If you created it from the management console, CloudFormation should have been created, so you may want to try deleting it from the CloudFormation console.

profile picture
EXPERT
answered 2 months ago
profile picture
EXPERT
reviewed 2 months ago
0

Hi Miguel,

Did you resolve this issue without premium support? How did you get help from AWS tech team? We are asking this because we have similar issues.

Thanks.

Chulhan
answered a month ago
  • Hi Chulhan,

    In our case it was a clear issue with the account - none of the documented solutions worked. Therefore, we were able to use the free "Account and Billing Support".

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions