By using AWS re:Post, you agree to the Terms of Use
/Attaching EBS Volume fails: Thinks it is attached to another instance but is not./

Attaching EBS Volume fails: Thinks it is attached to another instance but is not.

0

I created a volume from a snapshot. The Volume State is "Available". Nothing is listed under "Attached instances". I try to attach to an instance via the console - no issue selecting the instance. I get the message "volume is already attached to an instance".

Any thoughts on why it thinks it is attached?

2 Answers
0

I stopped the instance. The volume then attached with no problem. The error message of "volume is already attached to an instance" is apparently not identifying the actual issue to be resolved.

answered 4 months ago
  • After attachment, the instance will not start. Error in EC2 console is "Server.InternalError: Internal error on launch"

  • I tried making a new volume not using a snapshot and attaching it. It worked with no issues. Something about making the volume from a snapshot that is causing the issue.

0

I would raise a support ticket for this - it's not possible from this distance to see what might be happening.

EXPERT
answered 4 months ago
  • I created a fresh volume, attached it, and did a copy from an existing instance that had the volume mounted. As I found a workaround, I'll not be pursuing this further since it was for a one time migration. If this was an issue I was having frequent issues with, I'd pursue it. If someone else has this same issue, I encourage them to follow up with AWS and a support ticket.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions