PostgreSQL RDS minor version upgrade stuck with "Incompatible-parameters"

0

Hi AWS Support,

During a Production RDS maintenance (minor version upgrade from PostgreSQL 9.4.20 to 9.4.21), the instance has become stuck in "Incompatible-parameters" status.

The affected RDS resource ID is db-DZAT6VNZZ3JSXFDU6BQXRQOCJQ

The errors in the event log are:
-This DB instance was placed into incompatible-parameters status because the huge pages configuration for the instance would exceed 90% of the available instance memory. To fix this issue, modify the associated parameter group to lower the shared memory usage, and then reboot the instance. For more information, please refer to the RDS Postgres documentation
-Postgres could not be started due to incompatible parameters. Shared memory segment exceeded available memory or swap space. Please modify shared memory usage parameters to lower values and reboot the instance.

The maintenance only included minor version upgrade. Huge pages parameter is already set to OFF and we did not alter any parameters for this maintenance therefore we are unsure why the upgrade failed. To try and resolve the issue, we tried reducing max_connections, restarting the instance, but none of them worked.

This is a production instance and we had to urgently restore it using a different name.

To try replicate the issue, we created a test instance from the production snapshot with the same settings (instance class, parameters, etc), and tried the same upgrade again (9.4.20 -> 9.4.21) and this time it was successful.

Can you please check the cause of the upgrade failure? If upgrade failed, why is it not rolling back automatically? Also can you please allow the instance to be deleted so that it stops incurring further cost?

Regards,
James

aws-fm
asked 3 years ago202 views
2 Answers
0

We found a solution in another thread.

Solution:

  1. Use AWS CLI to disable Delete Protection
    aws rds modify-db-instance --db-instance-identifier db01 --no-deletion-protection

  2. Use AWS Console UI to delete RDS instance.

aws-fm
answered 3 years ago
0

Setting huge_pages to off resolved here. It is surely an RDS bug as just automatic minor upgrade triggered the issue

answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions