By using AWS re:Post, you agree to the Terms of Use

Amplify Console - custom domain shows different content than default url

1

After a successful deployment of our Angular app to our "prod" hosting environment, the changes are showing successfully in the default amplifyapp url (e.g. https://prod.1234567.amplifyapp.com) but NOT in our Route53 custom domain.

We've tried rebundling/redeploying a number of times with the same result. Wondering if there's an issue with the underlying CloudFront caching (we don't manage our own distribution), or if this is related to the way we configured the custom domain (although previous deployments have worked fine - this issue just arose today).

Any idea what we can do to fix this?

  • Deleting the custom domain and readding it worked, but still wondering how we got in this situation to begin with. Would appreciate any insight!

  • We're seeing exactly the same issue, and it seems to have started around when this post was made. I'd rather avoid deleting/recreating the custom domain if we can - are there any other suggestions for how to resolve this?

1 Answers
0

It looks like the Amplify service team is aware and working on this issue: https://github.com/aws-amplify/amplify-hosting/issues/2846

answered 25 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions