When I restart instance, SSM is connected. but after a few minute, SSM isn't connected.(Target Not Connected)

0

When I restart instance, SSM is connected. but after a few minute, SSM is connected.(Target Not Connected) How can I debug and solve this problem?

asked 2 years ago1467 views
2 Answers
0
profile pictureAWS
EXPERT
answered 2 years ago
0

Could you please check if SSM agent is installed. I am not sure which OS you are using. Please also make sure you are using AWS CLI v2.

Hence here is the link that might help https://docs.aws.amazon.com/systems-manager/latest/userguide/ssm-agent.html -- [1]

Check if all the steps are performed and also if the SSM installed on the instance is not out of date. You can discover this by trying to start the session from Systems Manager in the AWS console; basically going to Systems Manager->Fleet Manager->{INSTANCE_ID}->Instance Actions->Start Session It will throw an error if it is out of date.

https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-getting-started.html -- [2]

As mentioned in the link below, this error is also returned if you attempt to start a session on a managed node that is located in a different AWS account or AWS Region.

https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-troubleshooting.html#ssh-target-not-connected [3]

Once you verify the same, please check if the instances have the proper outbound connectivity? (Outbound to some AWS services including ec2messages.region.amazonaws.com, ssm.region.amazonaws.com, ssmmessages.region.amazonaws.com

profile pictureAWS
SUPPORT ENGINEER
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions