Issues with Net Use Logon Script GPO

0

Howdy! My workspaces environment is using AWS Simple AD. I was attempting to setup a mapped drive to an EC2 provisioned resource using a net use .bat script via logon GPO.

The GPO is showing in gpresult. The script can be run as a logged in user from the network path of the script and successfully maps the drives. I added an echo test to the end of the script and upon logon the echo creates the test file I indicated in the script. But for some reason when run at logon via GPO it will run the echo but not the net use commands.

1 Answer
0

Where is your login script saved? It really should be stored on the netlogon share.

Otherwise use the GPO native map network drives.

You could for debug purposes make sure your scripts are not hidden via gpo setting and place a pause in the script to see any errors

profile picture
EXPERT
answered a year ago
  • Hi, I had tried native mapped drives first. I just tried again given your response and still no luck, followed this specific tutorial this time to ensure all steps were correct. https://activedirectorypro.com/map-network-drives-with-group-policy/

    I wanted to post my scripts to netlogon share (sysvol) on the domain controller but given this is simple AD didn't see a method to perform that action in the AWS docs. I made a share on the EC2 provisioned resource and ensured domain users had read access. Are these just limitations to SimpleAD should I migrate to proper domain controller? Thanks!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions