By using AWS re:Post, you agree to the Terms of Use
/GameLift fleet spins/hangs after creation/

GameLift fleet spins/hangs after creation

0

Steps to reproduce:

  1. Open gamelift dashboard in us-west-1
  2. Click "create fleet"
  3. Populate the fleet creation fields
  4. Click initialize fleet

Expected: The UI loads briefly then shows provisioning details such as logs. The fleet should be visible in the list of fleets, perhaps in a provisioning state.

Actual: The fleet creation UI closes and is replaced with the amazon loading icon (two arrows that form a circle, spinning). This has persisted for over an hour.

I've tried different fleet details such as spot vs on-demand to no avail. There are no errors/logs present to suggest a failure.

Any ideas? Thanks!

asked 7 months ago19 views
3 Answers
1

Hi,

It turns out to be a race condition on the page. The team has already pushed a fix, and we'll send an update when the fix is deployed in the us-west-1 region.

A temporary workaround to this issue is to try creating the fleet again; however, after inputting all the values, waiting for 1 minute before hitting the "initializing fleet" button. This will prevent the race condition. Alternatively, you may use the aws CLI to create a fleet in the us-west-1 region if you continue to see the same issue.

Sorry for any inconvenience, and thanks again for letting us know!

answered 7 months ago
EXPERT
reviewed 7 months ago
0

Hi,

Thanks for reporting this, I was able to reproduce this on my end. Will reach out to the GameLift team to get this addressed as soon as possible.

Thanks!

answered 7 months ago
0

Hi,

Gamelift team has addressed this issue.

Thanks,

answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions