How to resolve Network Error -53 when trying to mount gateway on windows os?

0

So I'm trying to mount the storage gateway I've created on AWS as per this guide : https://docs.aws.amazon.com/filegateway/latest/files3/GettingStartedAccessFileShare.html

So far I've created a gateway which is being hosted on Amazon EC2 instance. Afterwards I created the file share of type NFS and now I'm trying to mount it using this command:

mount –o nolock -o mtype=hard [GatewayVMIPAddress]:/FileShareName WindowDriveLetter:

However I keep getting this error: Network Error - 53 which is "the network path was not found".

So far I've tried adding/changing port requirements of my ec2 instance by adding what amazon support recommends https://docs.aws.amazon.com/storagegateway/latest/userguide/Requirements.html#networks but still getting same error. Not sure what else I can try? Any help?

asked 9 months ago145 views
1 Answer
0

Hi, generally you would see this error when the storage gateway is not allowing all the three required NFSv3 ports. I would suggest verifying the gateway EC2 instance security group and check if it has allowed ports 20048, 111 and 2049 in its Inbound rules from the client IP address that you are trying to mount. You can verify network connectivity to these ports using Test-NetConnection PowerShell commands from the Windows client. Example command : Test-NetConnection -ComputerName <Gateway IP> -Port <PortNumber>

Surya
answered 9 months ago
  • I've ensured that all three inbound rules are present in the security group. Ports 20048 and 111 are of type Custom TCP, protocol TCP and the source is set to only my IP address. Port 2049 is type NFS and protocol TCP with the source set to only my IP address as well. In powershell all the netconnections failed. Is there something I have to configure in order to connect successfully?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions