Testing Anywhere websocket endpoint for GameLift

0

Hey all, I've been following multiple online tutorials on Anywhere fleet and I can't seem to connect my game server to the provided websocket after supplying the AUTH_TOKEN, HOST_ID, FLEET_ID, and PID (running my build on a linux server). I tried to use firecamp to test websocket with the supplied params but it failed as well. Below is the websocket I tried to test it with.

wss://us-east-1.api.amazongamelift.com?pID=123&sdkVersion=5&sdkLanguage=Cpp&Authorization=<authToken>&ComputeId=CustomContabo&FleetId=<fleet-id>

UPDATE: In the default GameLift server, When I call Init() in my game server with the 3.X library installed it works as expected. But if update the gamelift library to 5.X, my game server is unable to call Init() for some reason.

asked a year ago440 views
1 Answer
0

Hi,

When the websocket connection fails, is there a particular error message you are seeing? That would help us understand what could possibly be going wrong better.

If you are still facing issues please create a customer support case so the service team can help you debug this better.

Thanks!

AWS
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions