- Newest
- Most votes
- Most comments
Hello Yuze, hope you're doing good.
I noticed you're using DATA CATALOG in paramenter. Could you please check it?
"DATA CATALOG indicates that the external database is defined in the Athena data catalog or the AWS Glue Data Catalog. If the external database is defined in an external Data Catalog in a different AWS Region, the REGION parameter is required. DATA CATALOG is the default.
"IF NOT EXISTS A clause that indicates that if the specified schema already exists, the command should make no changes and return a message that the schema exists, rather than terminating with an error. This clause is useful when scripting, so the script doesn't fail if CREATE EXTERNAL SCHEMA tries to create a schema that already exists." https://docs.aws.amazon.com/redshift/latest/dg/r_CREATE_EXTERNAL_SCHEMA.html#r_CREATE_EXTERNAL_SCHEMA-parameters
Please accept this answer if it is helpful to you
answered 2 years ago
Relevant content
asked 4 years ago
asked 3 years ago
asked 3 years ago
- AWS OFFICIALUpdated 4 months ago

I was following the instructions on GitHub(https://github.com/aws-solutions-library-samples/guidance-for-digital-assets-on-aws/tree/main/analytics). I don't know what's wrong.