RDS SQL Server Instance Class cannot be modified.


For the last few days, I am trying to upgrade an RDS SQL Server web-edition instance from db.t2.small to db.t3.small. but every time i receive the following error.

We're sorry, your request to modify DB instance xxx has failed. Cannot modify the instance class because there are no instances of the requested class available in the current instance's availability zone. Please try your request again at a later time.

I have also used AWS CLI to check the orderable db-instances describe-orderable-db-instance-options This returns command also shows that orderable instances are available in us-east-1 with instance type as db.t3.small , but still i am unable to change the instance type. Is anyone facing the same issue or has a solution to this ?

2 Answers

A few questions! Which version of SQL Server are you using? And have you tried taking a snapshot and restoring into a db.t3.small to a different AZ in us-east-1?

answered a year ago
  • yes, i tried creating a NEW instance db.t3.small with the same sql server edition, and same AZ, and i was able to create it. so will have to use this option to upgrade the instance to db.t3.small. I am still wondering why the existing instance is unable to upgrade from db.t2.small to db.t3.small, if we can CREATE NEW instances in the same AZ with db.t3.small


Available instances vary across AZs. In our region we had some instance classes not available at all in one of the three AZs for quite a long time, until AWS eventually commissioned them in the third AZ. More likely though with a db.t3 is that they're just all already in use in that AZ so you can't get one. You may need to relaunch your DB in a different AZ.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions