By using AWS re:Post, you agree to the Terms of Use

AWS Serverless SaaS Workshop - Issue - Python Version -

0

Hi, I've been working on the following workshop - https://catalog.us-east-1.prod.workshops.aws/workshops/b0c6ad36-0a4b-45d8-856b-8a64f0ac76bb/en-US/pre-requisites/12-own-aws-account

In step 2 - Installing the Pre-requisites - you get an error regarding the Python version, even though the workshop says it installs 3.8. If you run python --version you get 3.7.10 on AL2. I tried to fix the issue by emoving the sym links and recreate them using 'sudo ln -s /usr/bin/python3.8 /usr/bin/python3' but that broke other things like YUM.

Apologize, if this is not the right forum for feedback and errors.

Anyone have suggestions on these workshops and getting them up and going?

  • oh, I also tried it, but it was Python 3.7.10...

    Checking python version
    Python 3.7.10
    ACTION REQUIRED: Need to have python version greater than or equal to 3.8.0
    
asked 5 months ago28 views
1 Answer
0

There's a typo in the prerequisites script. The previous version has the correct commands:

Admin:~/environment $ sudo alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 1
Admin:~/environment $ sudo alternatives --set python3 /usr/bin/python3.8
Admin:~/environment $ python3 --version
Python 3.8.5

The missing piece is the "1" that sets the priority for Python 3.8

You can see the previous commit here: https://github.com/aws-samples/aws-serverless-saas-workshop/commit/b3c667ab46efff1b26e537214553001840ccbbf2#diff-98187ed6eefbc5f2a831d13c69ea2e74ac780dc49ac64774e29e0020a6e4fea4

profile picture
answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions