AWS Serverless SaaS Workshop - Issue - Python Version -


Hi, I've been working on the following workshop -

In step 2 - Installing the Pre-requisites - you get an error regarding the Python version, even though the workshop says it installs 3.8. If you run python --version you get 3.7.10 on AL2. I tried to fix the issue by emoving the sym links and recreate them using 'sudo ln -s /usr/bin/python3.8 /usr/bin/python3' but that broke other things like YUM.

Apologize, if this is not the right forum for feedback and errors.

Anyone have suggestions on these workshops and getting them up and going?

  • oh, I also tried it, but it was Python 3.7.10...

    Checking python version
    Python 3.7.10
    ACTION REQUIRED: Need to have python version greater than or equal to 3.8.0
asked 2 years ago336 views
2 Answers

There's a typo in the prerequisites script. The previous version has the correct commands:

Admin:~/environment $ sudo alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 1
Admin:~/environment $ sudo alternatives --set python3 /usr/bin/python3.8
Admin:~/environment $ python3 --version
Python 3.8.5

The missing piece is the "1" that sets the priority for Python 3.8

You can see the previous commit here:

profile pictureAWS
answered 2 years ago

Thanks for reporting this issue. This issue has been fixed while ago.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions