Elastic Beanstalk Configuration Error Configuration validation exception

1

Going to Elastic Beanstalk, clicking on environment, trying to load Configurations and get the following error:

A problem occurred while loading your page: Configuration validation exception: Invalid option specification (Namespace: 'aws:ec2:instances', OptionName: 'InstanceTypes'): Your selected instance types (t3.xlarge) aren't available in your selected VPC Subnets. t3.xlarge is available in [us-east-1a, us-east-1b, us-east-1c, us-east-1d, us-east-1f]. Please check your VPC Subnets.

It seems that our t3.xlarge instance type is unavailable in zone us-east-1e. I don't know why this happened but our configuration is pooched. I tried removing the subnet from the VPC but it said I couldn't because the Network Interface was in use. I tried removing the subnet from our load balancer, database cluster and auto scaling group but we still get the error.

I noticed that most instance types are not available in us-east-1e but that t2.xlarge was and tried changing the launch configuration for the auto scaling group, but we still receive the error.

Finally, as a result of this error we cannot upload to the Elastic Beanstalk environment.

JMS
asked a year ago44 views
No Answers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions