Fehlermedung 'ClientError: Disk validation failed [Failed to read bytes of data from input]' bei dem Versuch ein OVA als Image zu importieren

0

Hello,

I want to import an OVA created on-prem under vSphere 7.0.3 into AWS as an AMI image. When trying to import the OVA I get the message:

VM Import task failed with taskId 'import-ami-0be80a3718530e59c', status = 'deleted' for ARN 'arn:aws:imagebuilder:eu-central-1:xyz:image/testtz1/1.0.0/1'. 'ClientError: Disk validation failed [Failed to read bytes of data from input]'

The OVA is not corrupt, I was able to test import it on various other platforms. I have also tried other OVAs with the same error. The OVA is a RedHat 8 Linux which is located in S3

TOm
asked 24 days ago180 views
1 Answer
0

Hi,

I have checked the AWS CloudTrail logs with source kms.amazonaws.com and noticed KMS:Decrypt API call is getting Access Denied at the same time as the VM Import task was created and it is for the vmimport IAM role.

The similar is mentioned on our troubleshooting section [+] as well which reads you need to assign additional Decrypt permission if you're S3 server-side encryption with KMS key and it provides permission JSON block which is required to resolve this error.

[+] https://docs.aws.amazon.com/vm-import/latest/userguide/vmimport-troubleshooting.html#import-image-errors

Once you have added the KMS Decrypt permission to the vmimport role, please rerun the import job and verify if it works.

AWS
SUPPORT ENGINEER
Jeff_B
answered 23 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions