By using AWS re:Post, you agree to the Terms of Use

ResourceInUseException: An error occurred (ResourceInUseException) when calling the DeleteDataset operation

0

I am having trouble with the deletion of Interactions Dataset. I was trying to delete the existing Dataset in my Dataset Group, in order to create a new one, with the boto3 delete_dataset() function (from a Sagemaker Notebook) when I recieved the following error: "ResourceInUseException: An error occurred (ResourceInUseException) when calling the DeleteDataset operation: Please delete all filters before deleting the dataset". I have no filters in the datasets, that is why I was confused. I tried also to delete the same dataset using the CLI, but recieved the same error message. I stoped the ACTIVE recommender in case there was a problem with that but the same error occurred. Can you help me with a solution for this error? Thank you in advance.

1 Answer
1
Accepted Answer

Since recommenders transparently create a filter to exclude recently watched content (VOD domain recommenders) or recently purchased items (e-commerce domain recommenders), I suspect that is what is triggering the error. Stopping the recommender must not be deleting this internal filter. Therefore, you will probably have to delete the recommender before the dataset can be deleted.

answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions

Relevant questions