Missing files for OTA update of greengrass core

0

I wanted to try performing an OTA update of my GGC but I ran into 2 problems:
1-I don't see a usr/scripts subdir in my greengrass directory (I'm running v1.7.1 on raspbian) nor can I find any ggc**.sh or ota**.sh scripts on my GGC
2-I can't follow the steps in https://docs.aws.amazon.com/greengrass/latest/developerguide/core-ota-update.html as they don't seem linear with respect to providing IAM policy and role information that isn't directly mappable to the example command. Is there a more robust doc for this?
Any help/guidance would be much appreciated!
Thx,
J

jlt190
asked 5 years ago214 views
2 Answers
0

Confirming that these files are missing for OTA (all the *.sh scripts) even when I get a success job submission to the GGC for an OTA. Anyone having the same problem. My OTA log on the GGC shows:
Fri Mar 29 11:45:06 2019: [FATAL ] pid:[26849]: [process_single_job_json]: Failed to execute pre install script ret 127
Fri Mar 29 11:45:06 2019: [ERROR ] pid:[26849]: [create_job_response]: Error Log: /greengrass/ota /packages/pre_install.sh: line 122: /greengrass/usr/scripts/ggc_pre_update.sh: No such file or directory
Pre update failed with exit 127
Failed to execute pre install script ret 127

Anyone solved? Downloading 1.8 directly shows there are no *.sh scripts in there either... Stumped!

jlt190
answered 5 years ago
0

...I'm going to assume that I misread the portion of the doc about the managedRespawn setting in config.json on GGC and that the *.sh files are user provided if required through that setting. So if my managedRespawn is false I shouldn't need them. I manually submitted a job and it seemed to work! So closing this and you can categorize it under RTFM. :)

jlt190
answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions