EFS mount failed


Please find this image for your reference Hi guys,

I created an EFS in my VPC. I tried to mount it on ec2 server in same VPC. But I am unable to attach it to instance. If I am using mount via IP it is showing connection timeout whereas NFS port is opened in EC2 server. On the other hand, If I try to mount it via DNS it is unable to resolve DNS whereas DNS settings are enabled for that VPC.

Can anyone please help me out.

1 Answer


Your issue is probably related with a not properly configured Security Group, that does not allow the connection between both systems.

Could you check if your EC2 instance security group allows outbound access to the mount target on the NFS, and if the NFS mount target security group allows inbound access from the EC2 security group?

Anyway, I recommend that you take a look at the Amazon Elastic File System (EFS) user guide, since it details how troubleshoot most mount issues, including your timeout error, as well as DNS name resolution fails.

profile picture
answered 4 months ago
  • It's also worth mentioning that as well as creating an EFS you also need to create a mount target, usually in the same AZ as your EC2 https://docs.aws.amazon.com/efs/latest/ug/accessing-fs.html

    This may be what's missing here, if it still doesn't work then the links in Mikel's answer should lead you to a solution.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions