How to resolve RDS MSSQL storage-full state?


Hi, I have an old SQL Server Web Edition (14.00.3381.3.v1) in storage-full state. What would be the best way to resolve this situation?

I have tried to follow e.g. guides:

I tried to add more storage but it stays in this state

            "PendingModifiedValues": {
                "AllocatedStorage": 200

I also tried to enable Storage autoscaling many days ago but it hasn't helped either.

From RDS events we can see the following:

Storage for tempdb log files is almost full. Shrink the tempdb files, or reboot the DB instance to reset the file size.
The free storage capacity for DB Instance: <name> is low at 0% of the provisioned storage [Provisioned Storage: 39.87 GB, Free Storage: 0 B]. You may want to increase the provisioned storage to address this issue.

But the suggested reboot is not an option as it's not allowed when db is in the storage-full state.

Connection to Database works and I have tried to understand and fix the issue, but unfortunately failed. Some information is below:

"2023-01-10 00:50:55.420"	"spid53"	"The transaction log for database 'msdb' is full due to 'LOG_BACKUP'."
"2023-01-10 00:51:01.290"	"Backup"	"Error: 18210, Severity: 16, State: 1."
"2023-01-10 00:51:01.290"	"Backup"	"BackupIoRequest::ReportIoError: write failure on backup device 'D:\rdsdbdata\BACKUP\mas***.database_backup'. Operating system error 112(There is not enough space on the disk.)."
"2023-01-10 00:51:01.290"	"Backup"	"Error: 3041, Severity: 16, State: 1."
"2023-01-10 00:51:01.290"	"Backup"	"BACKUP failed to complete the command BACKUP DATABASE mas***. Check the backup application log for detailed messages."
"2023-01-10 00:51:55.030"	"spid54"	"Error: 9002, Severity: 17, State: 2."


Database NameLog Size (MB)Log Space Used (%)Status

Shrinking the files hasn't been working for me with the command DBCC SHRINKFILE

Pretty much all the commands against msdb and rdsadmin databases have failed because of insufficient rights.

Even deleting the database (from the AWS console) fails with a message saying "We're sorry, your request to delete DB instance <name> has failed".

I'm not specialized MSSQL/RDS so any pointers on how to proceed would be highly appreciated!


1 Answer

I would recommend you enter the rdsadmin db and change the type of "recovery model" either from full to bulk-logged or from bulk-logged to simple.

After that try to do a RUN DBCC SHRINKFILE

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions