By using AWS re:Post, you agree to the Terms of Use
/NS record type disabled/

NS record type disabled

0

Hello there,

I'm attempting to create a child subdomain (lab.example.com) under a parent domain (example.com).

I'm trying to follow these instructions over here for creating the subdomain. It's that 8 step process near the bottom under the "To configure Route 53 to use the hosted zone for the subdomain (console)" heading.

I'm in the Route 53 console under the parent domain's hosted zone. I click "Create record". Notice that the NS record type (at the bottom) is greyed out/disabled?

Is there some security policy that is locking out that record type? Or is there some setting in the parent domain that I need to set before it will allow NS record types?


This set of instructions also goes over the process I'm attempting to enable.

Should I be using some other tool rather than the browser-based console? Something like the aws cli?

3 Answers
2
Accepted Answer

Make sure you are not working in a private hosted zone. NS records (and delegation) are not supported in this zone type.

answered 4 months ago
0

Make sure you are putting the subdomain (lab) in the "Record name" field of the "Create record" box. When you leave that blank, it greys out the NS record option because you can only have one NS record for that domain (example.com).

answered 4 months ago
  • That doesn't appear to be helping.

    • Click into the "Record name" text box with the mouse.
    • Type "lab".
    • Hit tab key 5 times (The "info" link next to "Record type", Skip past the "Record type" dropdown leaving "A" in place, the "info" link next to "Value", "Alias" switch, enters "Value" text box).
    • Ctrl+v/Paste in the name server values from the subdomain
    • Hit tab key one more time
    • Go back and select the "Record type" dropdown with the mouse
    • See that "NS" is still greyed out/disabled.

    Maybe a bug in the Javascript?

  • Ensure that Alias is not enabled as that would grey out the NS option.

0

If the UI does not work and you have followed the steps, you can try the CLI/API with the R53 change-resource-record-sets command / API.

Here are the instructions.

Generally API call will give you a more detailed reasons when it failed.

answered 4 months ago
  • Not sure why the answer has been down voted.

    It's unclear why people are trying to guess what's the issue instead of just try the API and get a more direct reason why the NS record cannot be created in the hosted zone.

    It's a very important technique because sometimes the UI does not give you any reason why certain operation is grayed out.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions