Multi cloud VPN connection to RDS

0

Hi, i've created a VPN connection from GCP to AWS following this guide: https://blog.searce.com/connecting-clouds-aws-gcp-771eb25a2dc3 Then i've created a vm con GCP and i've tested the connection to AWS. On AWS i've a Elasticache instance which i can connect without problems, but if i try with the RDS instance i've:

ERROR 2002 (HY000): Can't connect to MySQL server on '...' (115)

Security group and firewall rules seems right in AWS and GCP. Both Elasticache and RDS instance are in the same VPC and the same subnets group. I also tried to set "Public access" on RDS without results.

Some suggestions on that? Thanks

1 Answer
0

Hi.

Since it's on the same subnet as Elasticash, I don't think there's a network problem.

[Confirmation on AWS side]
Are the information such as the inbound port and source IP address of the RDS security group correct?

[Confirmation on Google Cloud side]
Can I create Cloud SQL for MySQL within Google Cloud and connect from a Google Cloud virtual machine?

profile picture
EXPERT
iwasa
answered 2 years ago
  • On AWS the security group rules seem correct (i tried with a 0.0.0.0/0 too), i tested the connection from the GCP instance to my backend on ECS with curl and it works.

    On GCP i've tested a VM with mysql and it works too. For now i can't test Cloud SQL instance because i need permissions and i'm waiting for the admin.

    Update: i've created an EC2 instance with mysql and i can connect on mysql from GCP

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions