Custom Identity Provider blank Message in response

0

I have a problem using the Custom Identity Provider, I am trying to setup the SFTP Transfer service using this page: https://docs.aws.amazon.com/transfer/latest/userguide/authenticating-users.html
I used this template https://s3.amazonaws.com/aws-transfer-resources/custom-idp-templates/aws-transfer-custom-idp-basic-apig.template.yml to create my CF stack and when I test authentication using the SFTP Transfer console I get the following:

{
"Response": "{"Role": "arn:aws:iam::0000000000:role/s3-sftp-transfer","HomeDirectory": "/"}",
"StatusCode": 200,
"Message": "",
"Url": "https://xxxxxxxxx.xxxxxxxx.amazonaws.com/prod/servers/s-xxxxxxxxxxxxxxxx/users/myuser/config"
}

According to the documentation, what I am getting in the "Response" field, should be in the "Message" field, and when I test with the AWS CLI test-identity-provider, I get the URL and statusCode, but again the "Message" field is blank.

Does anyone have any idea what I am doing wrong, or what I could check?

I manually tested the Lambda and the API Gateway and they both seem to work. I am not sure where to look next.

Thank you!

kio14
asked 3 years ago42 views
2 Answers
0

kio14:

Assuming you are using a valid Role ARN, you are seeing "message" as blank because your integration is working as expected. Have you tested with an SFTP client? Are you seeing any other indications that tell you it's not working?

Thanks,
Smitha

answered 3 years ago
0

Thanks for confirming Smitha, I was under the impression that the Message needed to contain the Role as per the documentation on the AWS site.

I will continue testing on my end with an SFTP client to see if I can get it to work.

Thanks again!

kio14
answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions