By using AWS re:Post, you agree to the Terms of Use
/Embedding a Quicksight QSearchBar for a user in a namespace (other than default)/

Embedding a Quicksight QSearchBar for a user in a namespace (other than default)

0

I am able to successfully embed Quicksight dashboards using the multitenancy (namespaces-based) approach described in Quicksight's documentation. However, when I try to embed a Q Search Bar, the request completes successfully, but it generates a blank iFrame. Are Q Search Bars only allowed to be embedded for users in the default namespace? If not, how can I go about granting access to Q Topics to users in different namespaces and successfully embedding the Q Search Bar?

Here are some additional details:

I've followed the Amazon Quicksight documentation for embedding dashboards for registered users as well as embedding the Q search bar for registered users. I've created a workflow that creates namespaces and uses row level security to restrict access based on namespaces / groups. While the dashboard embedding works fine for users created in their respective namespaces, the Q Search Bar embedding does not.

This applies even if I create a Q Topic from the same dashboard that I can embed successfully for the namespace user. In both cases, the result is simply a blank iframe where the Q Search Bar should appear. The actual call to GenerateEmbedUrlForRegisteredUser does not throw an error when attempting to embed the Q Search Bar for a user from the namespace - the returned link just generates a blank iFrame.

However, if I use same operation ( GenerateEmbedUrlForRegisteredUser) using the OWNER account in the default namespace, the embedded Q Search Bar works fine. This appears to suggest that there is some sort of permissions issue at play. I cannot find any documentation that covers how to use the API to grant access to a Q Topic to a user in a specific namespace. I've tried removing RLS as well, but the iFrame is still empty. Any help would be greatly appreciated.

asked 5 months ago8 views
2 Answers
0

Did you try it after creating and sharing the topic with that user? If it still doesn't work, please contact Customer Support with the details.

answered 5 months ago
0

This is the expected behavior as of now, since the search bar in embedded functions same as website. The user can utilize the onError callback in the SDK to be made aware when there are no topics. However, to make this more clear, we could provide a UX (in embedded mode only) that surfaces the error as well

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions