Device Farm - cannot find elements in iOS tests

0

Hello people,

I'm having a problem running tests on ios devices in device farm.
I have a react-native project that builds both android and ios application, with appium tests for both of them. I'm using webdriverio + appium.

The tests work locally, and on the android side I managed to make them work aswell in Device Farm.

The problem: when running iOS tests, the webdriver agents cannot find the elements (e.g. login form) of my ios application.
I keep getting "error: 'no such element' ". The application starts, and the webdriver calls seems correct, but at the end it cannot find a single element, and thus the tests fail.

I've tried changing the capabilities, host, path, wda, appium/node versions and a lot else, but to no avail.

Here is one of my recent run:
https://us-west-2.console.aws.amazon.com/devicefarm/home?region=eu-west-1#/projects/5ffc4bec-1370-4f5e-8823-4f5596a49b0d/runs/d67e226a-9526-4ddd-b0ea-627d092c7fd7

I would really appreciate some insights on this, I'm a bit out of ideas.

Thanks for your time!

asked 3 years ago469 views
2 Answers
0

Hi there,
Thank you for reaching out. Have you tried printing the page source during your tests to see what Appium is seeing during the test? Have you also confirmed that these work on a local device? Do you think any other Appium parameters are required to use these tests?

I have added an extra 1000 trial minutes to your account so you may continue testing.

Thank you,
Jon

AWS
answered 3 years ago
0

Hi Jon,

thanks for the answer.

So, I found the problem. It's kinda embarassing, but the problem was me using a .ipa file that was built on a different branch than the one that had my changes. After using the correct .ipa, the fields are found.

Thanks for the response, and sorry for taking your time for such a mistake on my part.

Have a great day!

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions