By using AWS re:Post, you agree to the Terms of Use
/I can't install Amplify on Cloud 9/

I can't install Amplify on Cloud 9

0

Whilst new to the AWS environment, Amplify, and Cloud9, I didn't think I'd be running into issues this early on.

I'm trying to install amplify in a new Cloud 9 environment, but for some reason, get this error off the bat. Any guidance or direction pointing would be highly appreciated:

Downloading release from https://d2bkhsss993doa.cloudfront.net/8.0.2/amplify-pkg-linux-x64.tgz

node:internal/buffer:959
    super(bufferOrLength, byteOffset, length);
    ^

RangeError: Array buffer allocation failed
    at new ArrayBuffer (<anonymous>)
    at new Uint8Array (<anonymous>)
    at new FastBuffer (node:internal/buffer:959:5)
    at createUnsafeBuffer (node:internal/buffer:1062:12)
    at allocate (node:buffer:410:10)
    at Function.allocUnsafe (node:buffer:375:10)
    at Function.concat (node:buffer:553:25)
    at Extract.<anonymous> (/home/ec2-user/.nvm/versions/node/v16.14.2/lib/node_modules/@aws-amplify/cli/lib/binary.js:124:37)
    at Extract.emit (node:events:538:35)
    at finishMaybe (/home/ec2-user/.nvm/versions/node/v16.14.2/lib/node_modules/@aws-amplify/cli/node_modules/readable-stream/lib/_stream_writable.js:624:14)
1 Answers
0

I had the same error in a t2.micro instance type (1GiB), but I solved creating a new Cloud9 environment in a t3.small instance type (2GiB).

answered 18 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions