Keys in super columns in external table are lowercase


All of my keys in super fields in external tables became lowercase.

Current result is {"id": 1, "super_field": {"camelcase":1,"uppercase":2,"lowercase":3}}

Should be {"id": 1, "super_field": {"camelCase": 1, "UPPERCASE": 2, "lowercase":3}}

My cluster updated to latest version 1.0.61559 . On the previous version 1.0.61191 everything works as expected.

Step to reproduce:

  1. Add jsonl file to s3:
{"id": 1, "super_field": {"camelCase": 1, "UPPERCASE": 2, "lowercase":3}}
{"id": 2, "super_field": {"camelCase": 5, "UPPERCASE": 6, "lowercase":7}}
  1. create external table
    external table test_external_db.test_table
    id int,
    super_field super
    WITH SERDEPROPERTIES ('ignore.malformed.json' = 'true')
    location 's3://';
  1. select * from test_external_db.test_table;
asked 2 months ago98 views
1 Answer

Hi, not explaining why the behaviour has changed. But have you tried forcing not to convert case : WITH SERDEPROPERTIES ("case.insensitive"= FALSE;) ?

profile pictureAWS
answered a month ago
  • Thanks for your answer. I tried it but it didn't help.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions