By using AWS re:Post, you agree to the Terms of Use
/RDS Aurora parameter group max_timeout custom setting not reflecting on the DB even after a reboot/

RDS Aurora parameter group max_timeout custom setting not reflecting on the DB even after a reboot

0

I'm trying to change an Aurora instance's max_timeout setting to 30 secs via a custom parameter group. I find the parameter and edit it and save. I see the DB instance shows modifying. When it's done if I connect to the DB instance and run the below the max_timeout value has not changed. I have even tried a reboot on the DB instance, again no luck. Why is this not working? Must I pay for support to create a case which is clearly an issue with AWS.

mysql> show variables like "%wait_timeout%";
+----------------------------------+----------+
| Variable_name                    | Value    |
+----------------------------------+----------+
| aurora_globaldb_rpo_wait_timeout | 60       |
| innodb_lock_wait_timeout         | 50       |
| lock_wait_timeout                | 31536000 |
| wait_timeout                     | 28800    |
+----------------------------------+----------+
4 rows in set (0.00 sec)

mysql>
  • Hi, @Motley.

    MySQL has multiple timeout related parameters, which parameter did you set to 30 seconds? innodb_lock_wait_timeout?

asked a month ago27 views
1 Answers
0

Hello, could you please verify which parameter was set for timeouts. Aurora does not have a max_timeout parameter.

answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions