connecting Route 53 domain to Big Cartel

0

Beginner programmer here, have been trying to get my Route 53 domain connected to my Big Cartel store all week with no luck. Here are Big Cartel's instructions: https://help.bigcartel.com/other-domain-providers

the steps are basically

  1. create a CNAME record with alias: www that points to mystore.bigcartel.com
  2. redirect non www URL's (ie mystore.com) to the www url with a 301 redirect without masking
  3. add domain to bigcartel account settings

These steps have become confused because I had to add cloudfront in there to get the SSL certificate, because I think I would need SSL for a store. So currently I have:

Route 53 with 2 A records (blank and www) pointing to cloudfront distro, and a CNAME which was auto generated by AWS certificate manager which points to a cloudfront address (different than cloudfront distro value)
Cloudfront points to S3 bucket, origin domain name path xxxx.s3-website-us-east-1.amazonaws.com
S3 bucket is set to static website hosting, redirects to mystore.bigcartel.com

Current the redirect works, but I can't get bigcartel to use the domain. I think I must be missing a CNAME setting, or do I change the AWS cert generated cname? Any advice GREATLY appreciated, thanks.

ssccdd
asked 3 years ago19 views
1 Answer
0

this seemed to work, in case anyone else is having the issue:

  1. in S3:
    -make a bucket with your store name (mystore.com) (no www)
    -enable public access
    -in permissions -> bucket policy, paste this code to allow people to see your bucket, changing url after resource to your corresponding domain
    {
    "Version": "2012-10-17",
    "Statement": [
    {
    "Sid": "PublicReadGetObject",
    "Effect": "Allow",
    "Principal": "",
    "Action": "s3:GetObject",
    "Resource": "arn:aws:s3:::mystore.com/
    "
    }
    ]
    }
    -in properties tab, under "Static website hosting", select "Redirect requests"
    -in the target bucket, write www.mystore.com, note www.
    -for protocol: http
  1. in Route 53:
    -make a CNAME record for www.mystore.com
    -alias: no
    -value: mystore.bigcartel.com

  2. in Route 53:
    -make an A record for mystore.com (no www)
    -alias: yes
    -alias target: if AWS does not auto populate your S3 bucket, as it did for me, pick the s3 url WITHOUT your domain name in there. For example, my s3 bucket is called mystore.com so the URL endpoint is mystore.s3-website-us-east-1.amazonaws.com. Just take this part " s3-website-us-east-1.amazonaws.com" and put that in Alias target

ssccdd
answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions