ERROR 2002 (HY000): Can't connect to local server through socket '/opt/bitnami/mariadb/tmp/mysql.sock' (111)

0

My website has a problem, Error establishing a database connection I fail to access to

/wp-admin/maint/repair.php

So tried to Recover A MariaDB Database. But there are Error message like this.

ERROR 2002 (HY000): Can't connect to local server through socket '/opt/bitnami/mariadb/tmp/mysql.sock' (111)

I appreciat you guyts if give some advice to solve the database problems

[sql log]

2022-09-15 11:51:53 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2022-09-15 11:51:53 0 [Note] InnoDB: Number of pools: 1
2022-09-15 11:51:53 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions
2022-09-15 11:51:53 0 [Note] InnoDB: Using Linux native AIO
2022-09-15 11:51:53 0 [Note] InnoDB: Initializing buffer pool, total size = 2147483648, ch
unk size = 134217728
2022-09-15 11:51:53 0 [Note] InnoDB: Completed initialization of buffer pool
2022-09-15 11:51:53 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=374566523
4,3747530277
2022-09-15 11:51:53 0 [ERROR] InnoDB: Missing FILE_CREATE, FILE_DELETE or FILE_MODIFY befo
re FILE_CHECKPOINT for tablespace 541
2022-09-15 11:51:53 0 [ERROR] InnoDB: Plugin initialization aborted with error Data struct
ure corruption
2022-09-15 11:51:53 0 [Note] InnoDB: Starting shutdown...
2022-09-15 11:51:53 0 [ERROR] Plugin 'InnoDB' init function returned error.
2022-09-15 11:51:53 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2022-09-15 11:51:53 0 [Note] Plugin 'FEEDBACK' is disabled.
2022-09-15 11:51:53 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2022-09-15 11:51:53 0 [ERROR] Aborting
profile picture
asked 3 months ago395 views
1 Answer
1

Hello,

Can you try the below mentioned approaches:

Firstly check if MySQL or MariaDB server is started. Check service mysql status

Specify 127.0.0.1 as the host instead of localhost. That is, mysql -h 127.0.0.1 -u root instead of mysql -h localhost -u root. If you omit the host (mysql -u root), the MySQL client will implicitly use localhost.

For SingleStoreDB Cloud, change the socket value in the /etc/mysql/my.cnf file to the location of your SingleStoreDB Cloud socket file.

This should help resolve the issue.

profile picture
SUPPORT ENGINEER
answered 3 months ago
  • I tried to check as below but it failed...

    mysqladmin -u root -p ping

    mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local server through socket '/opt/bitnami/mariadb/tmp/mysql.sock' (111)' Check that mariadbd is running and that the socket: '/opt/bitnami/mariadb/tmp/mysql.sock' exists!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions