By using AWS re:Post, you agree to the Terms of Use

Cannot set Lambda memory larger than 3GB

3

I currently have a Lambda function that has memory size set to 4GB. I am trying to increase it to 8GB, but am getting a weird error message about the memory value being limited to 3008: 'MemorySize' value failed to satisfy constraint: Member must have value less than or equal to 3008

See screenshot

The function was deployed with Terraform. Now it fails increasing the memory size using either Terraform or the Console.

Edit: the runtime is python3.8, in us-east-2. The account's quota for Lambda memory size is set to 10GB. Manually editing the function didn't help to 'reset' it's state or something of that sort.

Looks like a bug, but maybe I'm missing something?

  • Hi, couple of questions?

    UPD: I tried myself to upgrade a lambda memory to 8 GB for an outdated environment and it worked. So outdated environment is not a problem

  • @AWS-User-6196864 it's in us-east-2, not @Edge, and the runtime is python3.8

  • Any news on this? I do have the same problem here for runtime python 3.8 and regio eu-central-1. The account's quota for lambda functions is set to 10 GB. I checked other runtimes as well but see the same error.

  • Similar problem. Using CDK 1.148, recently bootstrapped account, ap-southeast-2, node runtime 14. Deploying Lambdas with memory set to 4 GB. Account quota says it can be 10 GB. Dropping the Lambda memory to 3008 worked.

  • Same here, python3.8 in ap-southeast-2. Quotas are OK, AWS console raises the same error.

asked 8 months ago1046 views
3 Answers
0

Can you check your quotas?

Service Quotas -> AWS services -> AWS Lambda -> Function memory maximum

Mine is set to 10GB but maybe yours got set to 3GB some time in the past.

profile picture
EXPERT
answered 8 months ago
  • Thanks for your response, it's set to 10,240MB. Other ideas?

0

I am facing the same issue on the newly created AWS accounts. We created the new AWS accounts for production. I got below response from the support team when I asked them about the issue. I don't know why AWS is doing this. There is no issue in the existing accounts.

Your account is still too new to access the full capacity of Lambda. It's recommended to new customers to use their account for up to six months before querying capacity access issues. I appreciate your patience while this issue was reviewed and I trust that it gives you more clarity on next steps. Thank you for choosing AWS!

answered 6 months ago
-2

Trying making changes to the AWS Lambda function using the AWS Management Console, that will help eliminate probable suspect areas.

answered 8 months ago
  • Which changes for example? Changing the timeout or memory via the Management Console didn't work

  • Also tried to download and redeploy the zip package through the Console, still the same error when trying to increase memory size

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions