Error when trying to register a windows on premise SSM agent (and missing error details)

0

I'm new to SSM, and just wanted to set up a test agent on a windows VM. I followed the hybrid environment tutorial. It resulted in the fowwlowing error, when running the agent installation script (in the $env:ProgramData\Amazon\SSM\Logs\erros.log file):

ERROR [processRegistration @ agent_parser.go.177] Registration failed due to error registering the instance with AWS SSM. InvalidActivation:

As you can see, the details about the InvalidActivation are missing... What can I do to track the error ?

  • Have you tried it on an EC2 to make sure the dependencies are all set up?

asked 8 months ago369 views
2 Answers
0

Hello

Please check the Activation Code, as the Error says the Code. is invalid. $code = "activation-code", How to create activation Code.

Here is the link to find the Activation https://eu-west-1.console.aws.amazon.com/systems-manager/activations/ Check for Activation ID and **Activation ID ** use in the CLI while running the command.

$code = "activation-code"
$id = "activation-id"
$region = "region"
$dir = $env:TEMP + "\ssm"
New-Item -ItemType directory -Path $dir -Force
cd $dir
(New-Object System.Net.WebClient).DownloadFile("https://amazon-ssm-$region.s3.$region.amazonaws.com/latest/windows_amd64/AmazonSSMAgentSetup.exe", $dir + "\AmazonSSMAgentSetup.exe")
Start-Process .\AmazonSSMAgentSetup.exe -ArgumentList @("/q", "/log", "install.log", "CODE=$code", "ID=$id", "REGION=$region") -Wait
Get-Content ($env:ProgramData + "\Amazon\SSM\InstanceData\registration")
Get-Service -Name "AmazonSSMAgent"
GK
answered 8 months ago
0

We just had this error occur as well, but on a LInux external instance. Generating a new activation code and id worked fine. I'm curious that the activation code that failed started with a / and also contained a +, the successful activation code was only [a-z,A-Z,0-9]

answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions