Remote reindex API AWS ElasticSearch Null Pointer Exception

0

Hi Everyone,

I tried to do remote re-indexing(Both domain's are in Opensearch 1.1 ) and received below error message.

{ "error" : { "root_cause" : [ { "type" : "null_pointer_exception", "reason" : null } ], "type" : "null_pointer_exception", "reason" : null }, "status" : 500 }

Originally I thought _source = false is set in my indexes, so I tested on new indexes that their _source was explicitly set to true , but still was receiving the same error message.

PUT my-index-000002 { "mappings": { "_source": { "enabled": true } } }

I would appreciate if you help me on this.

Thanks Aspet

asked 2 years ago1535 views
1 Answer
1

Hi there, "null_pointer_exception" is generally seen when there is no proxy in front of remote domain. You need to have a proxy in front of the remote domain (domain which has the index that needs to be reindexed) to be able to reindex it to the local domain from which you are issuing the request.

Even if both the domains are in the same VPC, the request when trying to reach the remote host, is considered to be external and does not resolve / authenticate to be able to reach the remote domain. Hence the need for proxy in front (1). If this is already setup, make sure the proxy domain has a certificate signed by a public certificate authority (CA) as self-signed. If you continue to run into same issue please open a support case with AWS premium support so that appropriate solution can be provided after troubleshooting.

(1) https://docs.aws.amazon.com/opensearch-service/latest/developerguide/remote-reindex.html

AWS
SUPPORT ENGINEER
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions